Non riesco ad aggiornare, aggiornare e rimuovere la mia app da kubuntu

Ho un problema con l’aggiornamento del software. Non riesco ad aggiornare, aggiornare o rimuovere il mio software.

La notifica del gestore aggiornamenti segnala 46 pacchetti di sicurezza e 83 altri pacchetti e quando faccio clic su di esso per installarli viene visualizzata un’altra finestra che viene scritta:

Non tutti i pacchetti potrebbero essere contrassegnati per l’aggiornamento. Gli aggiornamenti disponibili potrebbero richiedere l’installazione o la rimozione di nuovi pacchetti. Vuoi contrassegnare gli aggiornamenti che potrebbero richiedere l’installazione o la rimozione di pacchetti aggiuntivi?

E ho due possibilità:

Segna aggiornamenti o No

Indipendentemente dalla mia risposta ricevo due windows di errore:

Il primo è:

Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/c/coreutils/coreutils_8.13-3ubuntu3.1_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-pkg4.12_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-inst1.4_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apparmor/apparmor_2.7.102-0ubuntu3.4_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/a/apparmor/apparmor_2.7.102-0ubuntu3.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2_2.7.8.dfsg-5.1ubuntu4.2_i386.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2_2.7.8.dfsg-5.1ubuntu4.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.28-0ubuntu0.12.04.2_all.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.28-0ubuntu0.12.04.2_i386.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/tiff/libtiff4_3.9.5-2ubuntu1.3_i386.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/tiff/libtiff4_3.9.5-2ubuntu1.3_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server_5.5.28-0ubuntu0.12.04.2_all.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client_5.5.28-0ubuntu0.12.04.2_all.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-utils_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-transport-https_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-core-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-core-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/bind9-host_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/dnsutils_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libisc83_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libdns81_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libisccc80_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/python-problem-report_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/python-apport_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libisccfg82_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/liblwres80_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/apport_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/apport-kde_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/p/postgresql-9.1/libpq5_9.1.6-0ubuntu12.04.1_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libbind9-80_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-globalmenu_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-locale-en_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-installer_11.2.202.251ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2-utils_2.7.8.dfsg-5.1ubuntu4.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-generic_3.2.0.33.36_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-image-generic_3.2.0.33.36_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-headers-generic_3.2.0.33.36_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-headers-generic_3.2.0.33.36_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird-globalmenu_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/aptdaemon/aptdaemon_0.43+bzr805-0ubuntu6_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/aptdaemon/python-aptdaemon_0.43+bzr805-0ubuntu6_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird-globalmenu_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found 

Quando clicco su Ok, ne compare un altro:

Durante l’applicazione delle modifiche si sono verificati i seguenti errori: Pacchetto: ubuntu-keyring Dettagli Errore: sottoprocesso installato script di post-installazione restituito errore stato di uscita 127

Il secondo è:

 Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/c/coreutils/coreutils_8.13-3ubuntu3.1_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-pkg4.12_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-inst1.4_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apparmor/apparmor_2.7.102-0ubuntu3.4_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/a/apparmor/apparmor_2.7.102-0ubuntu3.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2_2.7.8.dfsg-5.1ubuntu4.2_i386.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2_2.7.8.dfsg-5.1ubuntu4.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.28-0ubuntu0.12.04.2_all.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.28-0ubuntu0.12.04.2_i386.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/tiff/libtiff4_3.9.5-2ubuntu1.3_i386.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/tiff/libtiff4_3.9.5-2ubuntu1.3_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server_5.5.28-0ubuntu0.12.04.2_all.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client_5.5.28-0ubuntu0.12.04.2_all.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-utils_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-transport-https_0.8.16~exp12ubuntu10.5_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-core-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-core-5.5_5.5.28-0ubuntu0.12.04.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/bind9-host_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/dnsutils_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libisc83_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libdns81_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libisccc80_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/python-problem-report_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/python-apport_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libisccfg82_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/liblwres80_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/apport_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/apport/apport-kde_2.0.1-0ubuntu15_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/p/postgresql-9.1/libpq5_9.1.6-0ubuntu12.04.1_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/b/bind9/libbind9-80_9.8.1.dfsg.P1-4ubuntu0.4_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-globalmenu_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox-locale-en_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-installer_11.2.202.251ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/libx/libxml2/libxml2-utils_2.7.8.dfsg-5.1ubuntu4.2_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-generic_3.2.0.33.36_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-image-generic_3.2.0.33.36_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-headers-generic_3.2.0.33.36_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/l/linux-meta/linux-headers-generic_3.2.0.33.36_amd64.deb 404 Not Found Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird-globalmenu_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/aptdaemon/aptdaemon_0.43+bzr805-0ubuntu6_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://it.archive.ubuntu.com/ubuntu/pool/main/a/aptdaemon/python-aptdaemon_0.43+bzr805-0ubuntu6_all.deb 404 Not Found [IP: 193.206.140.37 80] Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird-globalmenu_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found Failed to download http://security.ubuntu.com/ubuntu/pool/main/t/thunderbird/thunderbird_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb 404 Not Found 

Ho provato a correre:

sudo apt-get update

e poi

sudo apt-get upgrade o sudo apt-get dist-upgrade

ma

Quando sudo apt-get update questo è il risultato: http://paste.ubuntu.com/1468542/

Quando eseguo “sudo apt-get dist-upgrade”: http://paste.ubuntu.com/1468859/

Come posso risolvere il problema?

Modificare:

Leggendo gli errori, ho pensato che il problema potesse essere ubuntu-keyring. Ho cercato su ask.ubuntu e ho trovato questo link: Problemi di aggiornamento del sistema con apt-get

e ho provato:

 :~$ sudo rm -r /var/lib/apt/lists/* :~$ sudo apt-get update 

Ecco il risultato: http://paste.ubuntu.com/1475133/

e:

 :~$ sudo apt-get upgrade 

Ecco il risultato: http://paste.ubuntu.com/1475136/

Edit2:

Ho guardato l’errore e ho intuito che forse l’errore è libreadline. Ho chiesto qualcosa a riguardo qui: https://dba.stackexchange.com/questions/31143/libreadline-so-6/31177

E alla fine ho rimosso il file, ho aggiornato i sistemi con successo, ma quando ho riavviato il sistema il file rimosso era ancora lì. Quindi il problema rimane.

Grazie mille per avermi aiutato

Sembra che il gestore pacchetti stia cercando di recuperare pacchetti che non esistono più sul server. Questo accade quando le informazioni sul tuo sistema Ubuntu su quali pacchetti sono disponibili in quali versioni è scaduta.

Se si sta effettuando l’aggiornamento con il Software Center o con Update Manager, ciò non dovrebbe accadere, poiché si suppone che recuperino automaticamente informazioni aggiornate su quali pacchetti e versioni sono disponibili.

Tuttavia, se si sta utilizzando la riga di comando e si sta eseguendo solo sudo apt-get upgrade , questo è del tutto previsto. Quando si aggiorna il sistema o si installa il nuovo software dalla riga di comando, è necessario eseguire sudo apt-get update primo . Quindi, per aggiornare, esegui:

 sudo apt-get update sudo apt-get upgrade 

(Per assicurarti di essere aggiornato, ti consigliamo di eseguire sudo apt-get dist-upgrade per rilevare eventuali aggiornamenti che richiedono l’installazione o la rimozione di altri pacchetti. A meno che tu non abbia esperienza nel sapere quali pacchetti possono e non possono essere rimossi in sicurezza, raccomando di eseguirlo dopo sudo apt-get upgrade .)

Per una spiegazione più dettagliata del perché è importante eseguire sudo apt-get update e cosa fa ognuno dei comandi, dai uno sguardo a:

  • Cosa fa “sudo apt-get update”?