Come caricare “snd-hda-intel” all’avvio

Devo sempre digitare

  sudo modprobe snd-hda-intel 

per far funzionare la mia scheda audio ho già provato la soluzione per aggiungere snd-hda-intel a / etc / modules con

  sudo sh -c 'echo "snd-hda-intel" >> / etc / modules' 

La riga viene aggiunta di conseguenza nel file, comunque non sembra funzionare. Si prega di dare consigli.

modifica: ho eseguito

  dmesg |  grep snd 

-> nessun risultato.

dopo corro

  sudo modprobe snd-hda-intel 

e poi ho corso

  dmesg |  grep snd 

-> vedi output

produzione:

 [162.098807] snd_hda_intel 0000: 01: 00.1: Gestire il client audio VGA-switcheroo
 [162.134560] snd_hda_codec_realtek hdaudioC0D0: ALC892: SKU non pronto 0x598301f0
 [162.134978] snd_hda_codec_realtek hdaudioC0D0: autoconfig per ALC892: line_outs = 1 (0x14 / 0x0 / 0x0 / 0x0 / 0x0) tipo: altoparlante
 [162.134982] snd_hda_codec_realtek hdaudioC0D0: speaker_outs = 0 (0x0 / 0x0 / 0x0 / 0x0 / 0x0)
 [162.134985] snd_hda_codec_realtek hdaudioC0D0: hp_outs = 1 (0x1b / 0x0 / 0x0 / 0x0 / 0x0)
 [162.134988] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out = 0x0
 [162.134991] snd_hda_codec_realtek hdaudioC0D0: scavare = 0x1e / 0x0
 [162.134993] snd_hda_codec_realtek hdaudioC0D0: input:
 [162.134997] snd_hda_codec_realtek hdaudioC0D0: Mic interno = 0x19
 [162.134999] snd_hda_codec_realtek hdaudioC0D0: Mic = 0x18
 [162.135002] snd_hda_codec_realtek hdaudioC0D0: Line = 0x1a
 

Si prega di distriggersre l’avvio sicuro usando mokutil. Il mio ha avuto lo stesso problema ma ha funzionato disabilitando l’avvio sicuro.