Installa il rilascio stabile di xfce 4.12

Voglio installare la versione stabile di xfce 4.12 sul mio Xubuntu 14.04.2. Tuttavia, quando aggiungo il repository ( ppa:xubuntu-dev/xfce-4.12 ) tramite terminale, ricevo un messaggio su questi pre-release e ppa:xubuntu-dev/xfce-4.12 la data di rilascio finale … Tuttavia, la versione finale è già triggers ( sito Web xfce, due mesi fa).

  1. Perché ricevo un messaggio di avviso se la versione stabile è già stata rilasciata? Questo è leggermente fuorviante.

    Inoltre, tutti i post e le informazioni che vedo sull’installazione di xfce 4.12, vecchi (pre-rilascio, questo o questo ) o nuovi (post-release, questo ) seguono la stessa procedura (aggiungi dev-ppa).

  2. Come dovrei installare correttamente una versione stabile se non appare nei repository principali?

Quando esegui questo comando:

 sudo add-apt-repository ppa:xubuntu-dev/xfce-4.12 

e questo messaggio appare:

 Xfce 4.12 packages for currently supported versions of Xubuntu. Please note that these are pre-release versions, which may contain annoying bugs and/or crash. 

Quindi è solo un avvertimento. Esiste la possibilità che questo PPA possa fornire anche versioni instabili.


Ma puoi compilare la versione stabile .

Ecco le istruzioni per compilare dal sorgente, ad es. Per xfce-4.12:

 wget http://archive.xfce.org/xfce/4.12/fat_tarballs/xfce-4.12.tar.bz2 tar xf xfce-4.12.tar.bz2 cd src for f in *.tar.bz2; do tar xf $f; done 

Quindi in ogni cartella, ad esempio Thunar-1.6.6

 cd Thunar-1.6.6 ./configure make 

e installare con:

 make install 

o con checkinstall per i pacchetti .deb :

 sudo apt-get install checkinstall sudo checkinstall 

Ok, ho la risposta per la mia prima domanda. Ho aggiunto il repository e guardato il suo contenuto in synaptic. Quello che vedi c’è un sacco di pacchetti. Alcuni che ho installato (dato che ho xfce 4.10). Per quelli, alcuni sono aggiornati ma altri hanno una versione più recente. La chiave è quindi confrontare la versione di questi pacchetti più recenti con la versione stabile . E, voilà, per molti differiscono! Questo è, alcuni pacchetti hanno una versione più recente, oltre a quella stabile, il che ha perfettamente senso. Il dev ppa ti dà accesso alle versioni più recenti dei pacchetti, non a quelli stabili. La questione centrale qui quindi è che xubuntu-dev non fornisce un altro ppa con solo le versioni più nuove e stabili.

Tutto ciò significa che non è ansible installare la versione stabile di un meta-pacchetto (xfce) da dev-ppa! Il che implica che questo , questo , questo e parte di questi post siano errati (per quest’ultimo invito AB a scrivere la risposta corretta).

Così, cancellerò il ppa e compilerò il rilascio stabile come AB mostrato in un’altra risposta.

(Bello imparare qualcosa di nuovo su linux / ubuntu!)