Imansible connettersi e errore GPG su Ubuntu 14.04

Ho ricevuto il seguente errore quando ho apt-get update

Err http://extras.ubuntu.com trusty InRelease Err http://extras.ubuntu.com trusty Release.gpg Unable to connect to extras.ubuntu.com:http: Fetched 1,508 kB in 2min 5s (12.0 kB/s) Reading package lists... Done W: GPG error: http://ppa.launchpad.net trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78414460095F1873 W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/trusty/InRelease W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/trusty/Release.gpg Unable to connect to extras.ubuntu.com:http: W: Some index files failed to download. They have been ignored, or old ones used instead. 

Non ho idea di come risolvere questo problema.

puoi risolvere questo problema installando un software chiamato Y PPA Manager.
copia e incolla questi comandi nel terminale per scaricarlo e installarlo:

  1. sudo add-apt-repository ppa:webupd8team/y-ppa-manager
  2. sudo apt-get update
  3. sudo apt-get install y-ppa-manager

dopo questo lancio da dash. dopo averlo lanciato, selezionare l’opzione “Avanzate”, quindi fare clic su “Prova a importare tutte le chiavi GPG mancanti”. Quindi attendi fino a quando non ricevi la notifica che è stato fatto.
dopo questo clicca su “Prova a correggere tutti gli errori GPG BADSIG”. Attendi fino a quando non ricevi la notifica che è stato fatto.
quindi prova ad aggiornare, non avrai alcun errore. commento se avete qualche problema

È ansible farlo senza utilizzare strumenti esterni (ad eccezione ovviamente di Google ). Una soluzione è menzionata in questa domanda. Aggiungere una chiave GPG è facile. Hai bisogno dell’ID del pubkey che manca e viene visualizzato nel messaggio di errore che ricevi. Nel tuo caso, l’ID è 78414460095F1873. È ansible correggere l’errore facendo

 sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2EA8F35793D8809A