Dual boot Ubuntu 14.04.3 LTS con Win 10 su dischi rigidi separati

Ho installato 14.04.3×64 LTS su hd1 con Win10 esistente su hd0, usando un USB live. Nessun avvio sicuro, nessun BIOS Sono state selezionate solo le opzioni UEFI dal firmware delle opzioni di avvio sul desktop HP.

Le mie intenzioni erano di installare Ubuntu assicurandoti che entrambi i sistemi operativi caricassero, quindi tornassi indietro e configuralo nella directory / boot / efi / EFI / refind della nuova installazione di Ubuntu, come sul mio portatile.

Ubuntu ha funzionato alla grande, l’ho aggiornato suonando e riavviato in Windows. Windoze ha funzionato e poi … Opps! Quando il riavvio del menu di avvio di Windows mi ha dato l’opzione di Win e Ubuntu. Selezionando Ubuntu non è stato ansible trovare Grub2 o l’avvio di Windows.

Sono tornato alla chiavetta USB live e ho installato l’utilità Boot Repair e pubblicato i risultati di boot-info sull’URL di pastebin: http://Paste.Ubuntu.com/14524321/

L’utilità di avvio indicava che non c’era MBR su sda o sdb. La mia comprensione era che avrei richiesto solo una partizione efi e l’avvio di Ubuntu avrebbe una sezione EFI.

Sono confuso su come procedere. L’utility dice che usare diskpart e creare partizioni MBR da 150 a 250 MB e lo strumento di utilità posizionerebbe Grub2 in questo caso, quindi Ubuntu si avvierebbe.

Penso che se riesco a riavviare Ubuntu da sdb2 dall’ordine di avvio efi che ho impostato nel mio menu del firmware, ho potuto configurare REFInd all’avvio di Ubuntu come documentato sui documenti web di reflu. Dopo averlo fatto, sarei in grado di scegliere il sistema di avvio efi rilevato che dovrebbe includere Win 10.

L’unico accesso che ho ora alle unità è attraverso l’unità Try Ubuntu su / dev / sdc.

Grazie per eventuali suggerimenti.

Sembra che tu abbia un HP. Molti HP hanno noti bug EFI che impediscono loro di avviare qualsiasi cosa tranne Windows tramite il normale meccanismo di ordine di avvio EFI. Questo potrebbe essere il tuo problema; però….

Non ci sono prove di GRUB sulla tua partizione di sistema EFI (ESP; /dev/sda2 nel tuo caso). Questo potrebbe essere una svista di Boot Repair / Boot Info Script; a volte omette i file caricatore di avvio validi. Potrebbe anche essere che i file siano “scomparsi” a causa di un errore del filesystem. Ciò può accadere perché non è stata distriggersta la funzionalità “Avvio rapido” in Windows 8 e versioni successive. In Windows 8, puoi farlo come descritto qui, tra l’altro. In Windows 10, le istruzioni sono qui, tra l’altro. Potrebbe essere necessario disabilitare la modalità di sospensione, come descritto qui. Si noti che la distriggerszione di Fast Startup non risolverà alcun danno al file system già esistente, quindi potrebbe essere necessario utilizzare Boot Repair o qualche altro strumento per reinstallare GRUB. In alternativa, dal momento che si desidera utilizzare RIPERd a lungo termine, è ansible saltare GRUB – utilizzare rEFInd su un’unità flash USB o CD-R (è ansible ottenere immagini dalla sua pagina di download ), avviare Ubuntu utilizzandolo e installare REFInd.

Ho risolto questo problema utilizzando rEFInd e i documenti forniti da http://www.rodsbooks.com. Dopo aver installato Ubuntu 14.04.3 dalla USB dal vivo e aver eseguito il programma, alcuni sono tornati a Windows 10. Questo ha funzionato fino al riavvio di Ubuntu, che non mi ha dato alcun menu di avvio per Windows o Ubuntu.

Sono stato in grado di recuperare entrambi i dischi rigidi con il rispettivo sistema operativo utilizzando il CD di avvio di RIPRODUZIONE . Questo mi ha dato il menu di avvio di Windows e Ubuntu.

Dopo essere entrato nella nuova installazione di Ubuntu sul mio secondo disco, ho eseguito la procedura di installazione descritta per Ubuntu da http://www.rodsbook.com e la documentazione di recupero.

Ora doppio avvio utilizzando il menu RIPETI senza problemi.