Unity non viene caricato dopo l’installazione dei driver NVIDIA

Se installo uno dei driver NVIDIA proprietari (nvidia– *) dai repository, Unity non viene caricato dopo l’accesso. Ho appena ottenuto uno sfondo del desktop vuoto senza icone, pannelli o launcher.

Se disinstalla di nuovo i driver, il desktop si carica correttamente, ma alcuni giochi non funzionano correttamente.

C’è un modo per risolvere questo? Grazie.

Mi è successo questo su Ubuntu 14.10 x86_64 con il kernel 3.16.0-28 dopo aver caricato i driver Nvidia 346. Dopo l’accesso otterrei lo sfondo vuoto di Ubuntu e nient’altro, nessun modo di fare nulla. Ci sono molti problemi simili pubblicati online negli ultimi quattro anni; la maggior parte delle soluzioni non ha funzionato per me. Tentativo di riavviare l’unità, ho ricevuto un errore: compiz: plugin OpenGL non caricato .

Infine, questo è ciò che ha funzionato:

CTRL-ALT-F3 < ...to reach console, and then login. > sudo apt-get install --reinstall ubuntu-desktop sudo apt-get install unity sudo killall nvidia-persistenced sudo apt-get purge nvidia* < see the error message, and get the process ### > sudo kill -9 ### < ... ### is from previous error; a process locking user "nvidia-persistenced" > sudo apt-get purge nvidia* sudo apt-get install nvidia-prime sudo reboot < ...wait... > CTRL-ALT-F3 < ...to reach console, and then login. > export DISPLAY=:0 sudo dconf reset -f /org/compiz/ gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins <...note space after 'core/' and before 'active-plugins' > sudo reboot 

… e poi ha funzionato. Mi piacerebbe non dover passare di nuovo a quello!

Vedi anche: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1166765 e https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1342339

Prima opzione: scarica i driver da http://nvidia.com/object/unix.html , non da repository. Dopo aver installato il riavvio del computer.

2a opzione: riavvia il computer dopo aver installato i driver nvidia dai repository.