Wifi non può connettersi prima di cablare. Come diagnosticare cosa potrebbe andare storto (quali log, ecc.)?

Penso che questo sia un problema legato a un altro che ho avuto , ma ecco la prima situazione:

  • Quando avvio e mi collego al wireless, mi viene detto che mi connetto alla mia rete wireless.
  • Tuttavia, non riesco a collegarmi a Internet. (Le pagine scadono e dicono non connesso.)

Nella seconda situazione: quando avvio e mi collego via et, la mia connessione va bene – posso quindi collegarmi simultaneamente al wireless. – Dopo aver rimosso la connessione Ethernet, ho wireless che funziona bene e mantiene la mia connessione.

Non sono sicuro di quale sia il meccanismo di root che sta causando questo problema, ma sospetto che sia correlato ai problemi di xorg e libglib2 che ho riscontrato e sto risolvendo altrove. Tuttavia, per confermare le mie impressioni, quale file di registro dovrei essere in grado di identificare anche perché questo sta accadendo? Mi sto occupando di questa domanda per un elenco di luoghi che dovrei cercare di diagnosticare questo problema folle, dato che esiste un comportamento che funziona in modo diverso a seconda dell’ordine di connessione.

(Un’altra nota, so che questo ha funzionato nel recente passato, quindi non è un problema della scheda wireless stessa.)

AGGIORNAMENTO La banda larga mobile ha lo stesso problema. Non funziona se non mi connetto per la prima volta alla connessione cablata e allo stesso tempo mi collego alla banda larga prima di rimuovere la connessione cablata. Aiuto per favore!

AGGIORNAMENTO 2 Dimentica la diagnosi, qualcuno può risolvere questo problema per favore? Sono stato in Windows per una settimana perché non posso usare la rete wifi!

/var/log/syslog dovrebbe darti qualche informazione su cosa sta succedendo con le tue connessioni, potresti anche trovare alcune informazioni in /var/log/kernel .