Problemi con dual boot (Ubuntu + Windows), UEFI e SSD

Sembra che molte persone abbiano problemi con questo, ma non ho visto il mio caso in particolare.

Ho un portatile con SSD + HDD. L’SSD ha 2 partizioni, 1a partizione ha Windows 10 (che si avvia solo in modalità UEFI), la seconda partizione è vuota, che voglio installare Ubuntu.

Sto usando YUMI per avviare in Ubuntu e qui inizia la follia:

Bene, quindi 1) Perché Ubuntu non riconosce il mio SSD in UEFI? 2) Se posso farlo solo in Legacy, dovrei reinstallare Windows in Legacy (volevo davvero evitarlo)? 3) Qual è l’opzione migliore qui?

PS. L’ubuntu che ho scaricato è 16.04.1

EDIT: Quindi qui va più informazioni sul mio sistema.

  • Sistema: Alienware 17 R3
  • Versione del BIOS: 1.3.6
  • Informazioni SSD: PM951 NVMe SAMSUNG 256 GB
  • Funzionamento SATA: RAID (l’altra opzione non selezionata è AHCI).

Il rapporto di riparazione all’avvio è in: http://pastebin.com/HSzTZfSz

EDIT 2: ho cambiato l’operazione SATA da RAID a AHCI per testare e, abbastanza sicuro, Windows 10 non si avvia più, ma stranamente, Ubuntu live ora riconosce il mio SSD, e ancora più strano, identifica Windows come SO corrente e permettimi di installarlo a fianco. Così:

  • 1) Capisco che se voglio che i miei dischi funzionino con qualsiasi tipo di RAID (0,1,5) dovrò partire come RAID, che non è il mio caso, almeno per ora.

  • 2) Sarei ok con AHCI, ma come faccio a far riavviare Windows senza reinstallarlo? Se installo Ubuntu insieme a Windows, risolverà il bootloader? Devo eseguire Repair-boot tool?

  • 3) Cosa sta succedendo davvero qui? Ubunto non ha unità RAID per il mio laptop? Qualche idea?