Qual è la differenza tra libavcodec-ffmpeg-extra56 e libavcodec-ffmpeg56? Quale dovrei installare?

Come dice il titolo: Qual è la differenza tra libavcodec-ffmpeg-extra56 e libavcodec-ffmpeg56? Quale dovrei installare?

Sto usando kdenlive ma sto ascoltando alcuni altri editor video non lineari. Importa quale di questi pacchetti è installato, presumibilmente uno è per ffmpeg e uno è per la versione bawdlerised di Ubuntu (o è avconv ora?)?

Consiglio per favore?

Modifica, da packages.ubuntu.com :

Pacchetto libavcodec-ffmpeg-extra56

xenial (16.04LTS) (libs): FFmpeg library with **additional** de/encoders for audio/video codecs [universe] 7:2.8.8-0ubuntu0.16.04.1 [security]: amd64 i386 7:2.8.6-1ubuntu2 [ports]: arm64 armhf powerpc ppc64el s390x 

Pacchetto libavcodec-ffmpeg56

 xenial (16.04LTS) (libs): FFmpeg library with de/encoders for audio/video codecs - runtime files [universe] 7:2.8.8-0ubuntu0.16.04.1 [security]: amd64 i386 7:2.8.6-1ubuntu2 [ports]: arm64 armhf powerpc ppc64el s390x 

Se si guardano i file ( plain , extra ) l’unica differenza sembra essere il file in /usr/share/lintian/overrides/ . I file .so sono identificati con nome e versione.

libavcodec-ffmpeg-extra56 aggiunge alcuni encoder aggiuntivi, ma generalmente inutili:

  • libopencore_amrwb – Adaptive Multi-Rate Wide ( AMR-WB ). Un formato obsoleto utilizzato nei vecchi telefoni.
  • libopencore_amrnb – Adaptive Multi-Rate NarrowBand ( AMR-NB ). Un altro formato obsoleto utilizzato nei vecchi telefoni.
  • libvo_aacenc – codificatore audio AAC-LC. Questo è stato rimosso a monte in FFmpeg poiché è un codificatore scadente e il codificatore AAC FFmpeg nativo ( -c:a aac ) è migliore.

Quindi non vi è alcun motivo per installare questo particolare pacchetto a meno che non sia necessario codificare in AMR. Non ho mai avuto bisogno di farlo.

Ubuntu non utilizza più nulla dalla fork Libav incluso avconv . Usa ffmpeg .

Sembra che libavcodec-ffmpeg-extra56 sia un pacchetto di Ubuntu, che potrebbe essere stato rinominato o rielaborato in modo specifico per Ubuntu. Sembra che contenga le stesse informazioni e abbia le stesse dipendenze del pacchetto Debian libavcodec-ffmpeg56 . Potrebbe essere semplice come rinominare per rimanere in linea con lo schema di denominazione di Ubuntu.

Ecco l’ elenco delle dipendenze del pacchetto di Ubuntu

Sembra che l’originale libavcodec-ffmpeg56 sia di Debian.

Ecco l’ elenco delle dipendenze del pacchetto Debian

Se stai usando l’elenco di fonti di Ubuntu predefinito, ti suggerisco di installare il pacchetto standard libavcodec-ffmpeg-extra56 . Penso che forse hai altre fonti abilitate che ti mostrerebbero entrambe le cose?