Perché gli avviatori di pannello 8.04 non funzionano su 10.04

Ho copiato i miei programmi di avvio del pannello dalla 8.04 alla 10.04, risiedendo in entrambi i sistemi nello stesso percorso:

$HOME/.gnome2/panel2.d/default/launchers 

Tuttavia, per qualche motivo, non sono visibili sul pannello GNOME della 10.04.

Perché?

Aggiornamento 1 : nei miei tentativi di risolvere il problema I:

  1. Verificato che i launcher copiati 8.04 hanno le stesse autorizzazioni dei lanciatori 10.04 creati manualmente (-rwxr-xr-x).
  2. Aggiunta la prima riga come: #! / Usr / bin / env xdg-open
  3. Disconnesso, quindi connesso.
  4. Riavviato.

Aggiornamento 2 : ho creato manualmente un nuovo launcher che duplicherebbe la funzionalità di uno copiato. Questo ovviamente si presenta e così sono andato avanti e ho confrontato i due, passo dopo passo, portandoli ad essere identici ! (percorsi di icone copiati, quindi rimosso la riga ‘Codifica = UTF-8’, ecc.).

    Nessuno dei precedenti ha aiutato. Quindi la domanda rimane: perché?

    C’è qualche tipo di “registro” là fuori?

    I launcher sono registrati in sottocartelle di /apps/panel/objects nel database delle impostazioni di GConf :

    Editor di configurazione che mostra la registrazione all'avvio di gnome-terminal

    Per eseguire il backup di tutti i lanciatori di pannelli, dovrai copiare sia i lanciatori che le relative registrazioni:

    1. launcher: $HOME/.gnome2/panel2.d/default/launchers/
    2. registrazioni: $HOME/.gconf/apps/panel/objects/