16.04 – Errori Radeon R7 M260

Sto eseguendo Xubuntu 16.04 sul mio HP Elitebook 840 G2 e ho ricevuto diversi messaggi di errore a causa della mia Radeon R7 M260X .

dpkg -l | grep amdgpu ii libdrm-amdgpu1:amd64 2.4.67-1 amd64 Userspace interface to amdgpu-specific kernel DRM services -- runtime ii xserver-xorg-video-amdgpu 1.1.0-1 amd64 X.Org X server -- AMDGPU display driver 

Ho anche esaminato le caratteristiche del driver anche se non so cosa leggere da loro.

Errori in dmesg:

 [ 15.188843] radeon 0000:04:00.0: WB enabled [ 15.188846] radeon 0000:04:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff88044519dc00 [ 15.188848] radeon 0000:04:00.0: fence driver on ring 1 use gpu addr 0x0000000040000c04 and cpu addr 0xffff88044519dc04 [ 15.188849] radeon 0000:04:00.0: fence driver on ring 2 use gpu addr 0x0000000040000c08 and cpu addr 0xffff88044519dc08 [ 15.188851] radeon 0000:04:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff88044519dc0c [ 15.188852] radeon 0000:04:00.0: fence driver on ring 4 use gpu addr 0x0000000040000c10 and cpu addr 0xffff88044519dc10 [ 15.190426] radeon 0000:04:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc90002435a18 [ 15.291338] radeon 0000:04:00.0: VCE init error (-110). [ 15.363600] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [ 15.363602] Bluetooth: BNEP filters: protocol multicast [ 15.363606] Bluetooth: BNEP socket layer initialized [ 15.420411] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready [ 15.422122] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled [ 15.423579] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled [ 15.484757] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled [ 15.486214] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled [ 15.517056] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready [ 15.792955] [drm] ring test on 0 succeeded in 1 usecs [ 15.792963] [drm] ring test on 1 succeeded in 1 usecs [ 15.792968] [drm] ring test on 2 succeeded in 1 usecs [ 15.792979] [drm] ring test on 3 succeeded in 5 usecs [ 15.792987] [drm] ring test on 4 succeeded in 5 usecs [ 15.796040] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready [ 15.969028] [drm] ring test on 5 succeeded in 2 usecs [ 15.969035] [drm] UVD initialized successfully. [ 15.969071] [drm] ib test on ring 0 succeeded in 0 usecs [ 15.969100] [drm] ib test on ring 1 succeeded in 0 usecs [ 15.969128] [drm] ib test on ring 2 succeeded in 0 usecs [ 15.969156] [drm] ib test on ring 3 succeeded in 0 usecs [ 15.969184] [drm] ib test on ring 4 succeeded in 0 usecs [ 15.997342] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready [ 16.133308] input: ST LIS3LV02DL Accelerometer as /devices/platform/lis3lv02d/input/input24 [ 16.185402] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready [ 19.379164] e1000e: enp0s25 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None [ 19.379194] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready [ 26.117646] radeon 0000:04:00.0: ring 5 stalled for more than 10000msec [ 26.118368] radeon 0000:04:00.0: GPU lockup (current fence id 0x0000000000000002 last fence id 0x0000000000000004 on ring 5) [ 26.118479] [drm:uvd_v1_0_ib_test [radeon]] *ERROR* radeon: fence wait failed (-35). [ 26.119262] [drm:radeon_ib_ring_tests [radeon]] *ERROR* radeon: failed testing IB on ring 5 (-35). [ 28.617118] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel [ 28.622099] vboxdrv: Found 4 processor cores [ 28.653735] vboxdrv: TSC mode is Invariant, tentative frequency 2593994008 Hz [ 28.653738] vboxdrv: Successfully loaded version 5.0.18_Ubuntu (interface 0x00240000) [ 28.658096] VBoxNetFlt: Successfully started. [ 28.661211] VBoxNetAdp: Successfully started. [ 28.666592] VBoxPciLinuxInit [ 28.668608] vboxpci: IOMMU not found (not registered) [ 33.034688] wlo1: authenticate with 0c:27:24:e0:4b:4f [ 33.040075] wlo1: send auth to 0c:27:24:e0:4b:4f (try 1/3) [ 33.055172] wlo1: authenticated [ 33.057851] wlo1: associate with 0c:27:24:e0:4b:4f (try 1/3) [ 33.061858] wlo1: RX AssocResp from 0c:27:24:e0:4b:4f (capab=0x11 status=0 aid=2) [ 33.062970] wlo1: associated [ 33.063011] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready [ 33.254016] cfg80211: Regulatory domain changed to country: AT [ 33.254020] cfg80211: DFS Master region: ETSI [ 33.254021] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time) [ 33.254024] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A) [ 33.254026] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A) [ 33.254028] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s) [ 33.254030] cfg80211: (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s) [ 33.254032] cfg80211: (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A) [ 33.256082] wlo1: Limiting TX power to 18 dBm as advertised by 0c:27:24:e0:4b:4f [ 34.168377] [drm] probing gen 2 caps for device 8086:9c98 = 5323c42/0 [ 34.168382] [drm] PCIE gen 2 link speeds already enabled [ 34.175492] [drm] PCIE GART of 2048M enabled (table at 0x00000000002E8000). [ 34.175594] radeon 0000:04:00.0: WB enabled [ 34.175596] radeon 0000:04:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff88044519dc00 [ 34.175597] radeon 0000:04:00.0: fence driver on ring 1 use gpu addr 0x0000000040000c04 and cpu addr 0xffff88044519dc04 [ 34.175599] radeon 0000:04:00.0: fence driver on ring 2 use gpu addr 0x0000000040000c08 and cpu addr 0xffff88044519dc08 [ 34.175600] radeon 0000:04:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff88044519dc0c [ 34.175601] radeon 0000:04:00.0: fence driver on ring 4 use gpu addr 0x0000000040000c10 and cpu addr 0xffff88044519dc10 [ 34.177137] radeon 0000:04:00.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc90002435a18 [ 34.277967] radeon 0000:04:00.0: VCE init error (-110). [ 34.741671] [drm] ring test on 0 succeeded in 2 usecs [ 34.741713] [drm] ring test on 1 succeeded in 1 usecs [ 34.741719] [drm] ring test on 2 succeeded in 1 usecs [ 34.741729] [drm] ring test on 3 succeeded in 4 usecs [ 34.741737] [drm] ring test on 4 succeeded in 4 usecs [ 34.917798] [drm] ring test on 5 succeeded in 1 usecs [ 34.918003] [drm] UVD initialized successfully. [ 34.918039] [drm] ib test on ring 0 succeeded in 0 usecs [ 34.918070] [drm] ib test on ring 1 succeeded in 0 usecs [ 34.918108] [drm] ib test on ring 2 succeeded in 0 usecs [ 34.918138] [drm] ib test on ring 3 succeeded in 0 usecs [ 34.918343] [drm] ib test on ring 4 succeeded in 0 usecs [ 45.066399] radeon 0000:04:00.0: ring 5 stalled for more than 10000msec [ 45.066402] radeon 0000:04:00.0: GPU lockup (current fence id 0x0000000000000004 last fence id 0x0000000000000006 on ring 5) [ 45.066449] [drm:uvd_v1_0_ib_test [radeon]] *ERROR* radeon: fence wait failed (-35). [ 45.066469] [drm:radeon_ib_ring_tests [radeon]] *ERROR* radeon: failed testing IB on ring 5 (-35). [ 45.497026] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun [ 46.925039] Bluetooth: RFCOMM TTY layer initialized [ 46.925046] Bluetooth: RFCOMM socket layer initialized [ 46.925051] Bluetooth: RFCOMM ver 1.11 

Ho anche caricato l’ output completo del mio dmesg.

lspci:

 lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) 04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal PRO [Radeon R7 M260] 

xrandr:

 xrandr --listproviders Providers: number : 3 Provider 0: id: 0x6e cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 9 associated providers: 2 name:Intel Provider 1: id: 0x41 cap: 0x6, Sink Output, Source Offload crtcs: 2 outputs: 0 associated providers: 2 name:OLAND @ pci:0000:04:00.0 Provider 2: id: 0x41 cap: 0x6, Sink Output, Source Offload crtcs: 2 outputs: 0 associated providers: 2 name:OLAND @ pci:0000:04:00.0 

Quando DRI_PRIME=1 glxinfo | grep "OpenGL renderer" DRI_PRIME=1 glxinfo | grep "OpenGL renderer" ottengo anche un sacco di errori come radeon: Failed to deallocate virtual address for buffer e l’ Error of failed request: GLXBadContext .

ha avuto lo stesso problema con una scheda grafica radeon simile.

ho installato la versione 4.6 del kernel mainline da qui:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety/

Ecco una guida per l’installazione:

https://wiki.ubuntu.com/Kernel/MainlineBuilds#Verifying_the_mainline_build_binaries

Dopo aver avviato il nuovo kernel, ho testato la scheda con il seguente comando e la modifica della scheda grafica di radeon funzionava:

 $ DRI_PRIME=1 glxgears -info