errore di cryptsetup durante l’aggiornamento sudo-apt

Setting up ubiquity-ubuntu-artwork (2.21.63.4) ... dpkg: dependency problems prevent configuration of ubiquity: ubiquity depends on cryptsetup; however: Package cryptsetup is not configured yet. dpkg: error processing package ubiquity (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. dpkg: dependency problems prevent configuration of ubiquity-frontend-gtk: ubiquity-frontend-gtk depends on ubiquity (= 2.21.63.4); however: Package ubiquity is not configured yet. dpkg: error processing package ubiquity-frontend-gtk (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. Setting up unattended-upgrades (0.90ubuntu0.7) ... Installing new version of config file /etc/init.d/unattended-upgrades ... Synchronizing state of unattended-upgrades.service with SysV init with /lib/systemd/systemd-sysv-install... Executing /lib/systemd/systemd-sysv-install enable unattended-upgrades Setting up unity-control-center-faces (15.04.0+16.04.20170214-0ubuntu1) ... Setting up vino (3.8.1-0ubuntu9.2) ... Setting up xfonts-utils (1:7.7+3ubuntu0.16.04.2) ... Setting up xserver-common (2:1.18.4-0ubuntu0.4) ... Setting up xserver-xorg-input-all-hwe-16.04 (1:7.7+16ubuntu3~16.04.1) ... Setting up xserver-xorg-video-all-hwe-16.04 (1:7.7+16ubuntu3~16.04.1) ... Setting up xul-ext-ubufox (3.4-0ubuntu0.16.04.1) ... Setting up appmenu-qt5 (0.3.0+16.04.20170216-0ubuntu1) ... Setting up kpartx (0.5.0+git1.656f8865-5ubuntu2.5) ... Setting up kpartx-boot (0.5.0+git1.656f8865-5ubuntu2.5) ... update-initramfs is disabled since running on read-only media Setting up liblouis-data (2.6.4-2ubuntu0.1) ... Setting up liblouis9:amd64 (2.6.4-2ubuntu0.1) ... Setting up oxideqt-codecs:amd64 (1.21.5-0ubuntu0.16.04.1) ... Setting up python3-louis (2.6.4-2ubuntu0.1) ... Processing triggers for gconf2 (3.2.6-3ubuntu6) ... Setting up evince (3.18.2-1ubuntu4.1) ... Setting up libmetacity-private3a:amd64 (1:3.18.7-0ubuntu0.3) ... Setting up metacity (1:3.18.7-0ubuntu0.3) ... Setting up nautilus (1:3.18.4.is.3.14.3-0ubuntu6) ... Setting up shotwell (0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1) ... Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ... Setting up apport-gtk (2.20.1-0ubuntu2.10) ... Setting up libreoffice-common (1:5.1.6~rc2-0ubuntu1~xenial2) ... Installing new version of config file /etc/bash_completion.d/libreoffice.sh ... Setting up libreoffice-style-galaxy (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-style-breeze (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libnss3-nssdb (2:3.28.4-0ubuntu0.16.04.2) ... Setting up libnss3:amd64 (2:3.28.4-0ubuntu0.16.04.2) ... Setting up libnss3-1d:amd64 (2:3.28.4-0ubuntu0.16.04.2) ... Setting up libreoffice-core (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-base-core (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-calc (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-gtk (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-gnome (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-writer (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-draw (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-impress (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-ogltrans (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-pdfimport (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up python3-uno (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-math (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up libreoffice-avmedia-backend-gstreamer (1:5.1.6~rc2-0ubuntu1~xenial2) ... Setting up liboxideqtcore0:amd64 (1.21.5-0ubuntu0.16.04.1) ... Setting up liboxideqtquick0:amd64 (1.21.5-0ubuntu0.16.04.1) ... Setting up liboxideqt-qmlplugin:amd64 (1.21.5-0ubuntu0.16.04.1) ... Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Processing triggers for dbus (1.10.6-1ubuntu3.3) ... Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ... Processing triggers for libc-bin (2.23-0ubuntu9) ... Processing triggers for systemd (229-4ubuntu19) ... Processing triggers for ureadahead (0.100.0-19) ... Processing triggers for resolvconf (1.78ubuntu4) ... Errors were encountered while processing: cryptsetup ubiquity ubiquity-frontend-gtk E: Sub-process /usr/bin/dpkg returned an error code (1) 

Nuovo a Linux, quindi sono perso!

Prima di eseguire nuovamente l’aggiornamento, puoi provare a configurare cryptsetup con sudo dpkg --configure cryptsetup dalla sudo dpkg --configure cryptsetup di comando. Se ciò non aiuta, puoi provare a configurare tutti i pacchetti che necessitano ancora di configurazione con sudo dpkg --configure --pending prima di provare a eseguire nuovamente l’aggiornamento.

Detto questo, se sei nuovo puoi anche usare un’applicazione con una GUI dopo aver risolto questo problema. Mi piace “synaptic”, ma probabilmente dovresti prima installarlo.

Il tuo problema è cambiato: in un commento, stai scrivendo che sudo dpkg --configure --pending non sudo dpkg --configure --pending nulla. Pertanto, i messaggi di errore incollati nella tua domanda non appaiono più in quel modo particolare. Il tuo problema originale è andato. Ora stai apparentemente vivendo in modo diverso.

Puoi provare sudo apt-get check per verificare i problemi di dipendenza. sudo apt-get -f install proverà a risolvere automaticamente i problemi di dipendenza.