Come aggiornare OpenGL Driver su Ubuntu 14.04 LTS

Recentemente ho aggiornato a 14.04, quindi ho installato il vapore e TF2. Ottengo questo messaggio di errore:

Imansible trovare il punto di accesso OpenGL ‘glGetError’! La tua scheda video non è supportata o il tuo driver OpenGL deve essere aggiornato.

Comunque, so che ho bisogno di aggiornare il mio driver OpenGL, la mia domanda è come faccio?

EDIT: ho installato mesa e inserito glxinfo | grep version glxinfo | grep version in Terminal e ottenuto questo,

inserisci la descrizione dell'immagine qui

inserisci la descrizione dell'immagine qui Nuova modifica: dopo aver esaminato la prima risposta, ho eseguito tutti i passaggi e riavviato il mio computer, quando ho lanciato il vapore all’avvio, ho ricevuto il seguente errore,

Stai attento quando usi il consiglio di Charles Green.

Nel passaggio sudo apt-get, potresti vedere:

 sudo add-apt-repository ppa:oibaf/graphics-drivers sudo apt-get update sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: account-plugin-windows-live libupstart1 Use 'apt-get autoremove' to remove them. The following packages have been kept back: libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles1-mesa libgles2-mesa libosmesa6 libosmesa6:i386 libva1 libwayland-egl1-mesa mesa-common-dev xserver-xorg-video-intel 

La parte fondamentale è che l’aggiornamento che volevo fare non si verificava:

 The following packages have been kept back: 

Tu dovrai:

 sudo apt-get install  

Ho finito per fare:

 sudo apt-get install libegl1-mesa libegl1-mesa-drivers xserver-xorg-video-intel libgl1-mesa-dri libglapi-mesa 

Per ulteriori informazioni su questo problema, vedere: “I seguenti pacchetti sono stati tenuti indietro:” Perché e come risolverlo?

Sembra che tu abbia una versione di OpenGl, solo non abbastanza nuova per eseguire l’applicazione che stai cercando.

Per ottenere una versione leggermente più recente dei driver OpenGl, consiglierei i driver oibaf dal sito web del launchpad : questi implementano OpenGl 3.0 e sono piuttosto stabili.

Per installare aprire una finestra di terminale e immettere

 sudo add-apt-repository ppa:oibaf/graphics-drivers sudo apt-get update sudo apt-get upgrade 

Per rimuovere, puoi usare ppa-purge

 sudo apt-get install ppa-purge sudo ppa-purge ppa:oibaf/graphics-drivers 

Ho scritto la mia correzione / risposta qui per questo stesso identico problema:

Ubuntu 14.04 “non è stato ansible trovare il punto di accesso OpenGL ‘glGetError’!”

Avere una lettura