Packet Tracer 7.1.1 si blocca all’avvio, Xubuntu 18.04

Ho installato la maggior parte, se non tutte le librerie QT per processet tracer 7.1.1 per funzionare, ma ora si blocca al momento del lancio. Viene visualizzata la schermata Splash, ma l’applicazione termina immediatamente.

Ecco un registro quando si avvia: https://pastebin.com/iajXpJZb

Esecuzione di Xubuntu 18.04.

AGGIORNAMENTO: il problema sembra essere correlato a “Crypto_add_lock ()” in base a un altro registro errori. Non sono sicuro di cosa significhi.

Sembra che tu abbia perso alcune dipendenze, puoi installarle con:

sudo apt-get install libqt5webkit5 libqt5multimedia5 \ libqt5xml5 libqt5script5 libqt5scripttools5 

Inoltre puoi provare il metodo dalla mia altra risposta per 16.04 LTS :

 cd /tmp wget http://mirrors.kernel.org/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb 

Ma anche dopo queste azioni a volte si blocca davvero con l’ Segmentation fault (core dumped) anche se lanciato direttamente con /opt/pt/bin/PacketTracer7 .

Vedi questa domanda con una grande idea di eseguirlo da GDB. Il problema deriva da un codice in CPT, che è collegato a LibSSL.

Poiché si tratta di software proprietario, è necessario chiedere a Cisco il supporto e / o il pacchetto speciale di deb per Ubuntu 18.04 LTS.

Sono stato in grado di risolvere questo problema in Ubuntu 18.04, seguendo i passaggi in questo link -> Packet Tracer 7 su Ubuntu 18.04 non può essere lanciato

Spero che ti aiuti!