Come disinstallare BOOST 1.49 e installare BOOST 1.54 in Ubuntu?

Ho una spinta 1.49 nel mio sistema di Ubuntu. E sto cercando di disinstallare boost 1.49 e rimuoverlo completamente dal mio sistema.

E dopo ciò installa il Boost 1.54.0

Mi è piaciuto per disinstallare 1.49 dal mio sistema –

 sudo apt-get --purge remove libboost-dev sudo apt-get --purge remove libboost-all-dev 

E dopo quello che faccio sotto comando per vedere la versione, dice ancora che ho 1.49

 cat /usr/include/boost/version.hpp | grep "BOOST_LIB_VERSION" // BOOST_LIB_VERSION must be defined to be the same as BOOST_VERSION #define BOOST_LIB_VERSION "1_49" 

Non sai perché?

E ho provato ad installare la versione Boost 1.54.0 in questo modo –

 wget http://sourceforge.net/projects/boost/files/boost/1.54.0/boost_1_54_0.tar.gz/download tar -xvzf boost_1_54_0.tar.gz cd boost_1_54_0/ ./bootstrap.sh --with-libraries=atomic,date_time,exception,filesystem,iostreams,locale,program_options,regex,signals,system,test,thread,timer,log sudo ./b2 install 

Ma ancora non mi sta mostrando la versione 1.54.0 di installazione installata?

Qualche suggerimento su come rimuovere BOOST 1.49 dal mio sistema e installare BOOST 1.54 nella mia macchina?

È necessario disinstallare il pacchetto libboost1.49-dev … in realtà, dovrebbe essere rimosso con un singolo sudo apt-get autoremove . Se non sei sicuro fai questo:

 dpkg -S /usr/include/boost/version.hpp 

Questo restituirà il pacchetto che ha questo file, quindi puoi:

 sudo apt-get autoremove package