Come aggiornare Ubuntu dal 16.10 al 17.10?

Non ho capito bene. Ho appena provato ad aggiornare un sistema Ubuntu Server dal 16.10 al 17.10 … Senza successo. Tutti i modi tipici di aggiornare un tale sistema Ubuntu non funzionano. do-release-upgrade mi dice: An upgrade from 'yakkety' to 'artful' is not supported with this tool. E apt dist-upgrade semplicemente dimmi: niente da aggiornare.

Ci sono tutorial che utilizzano entrambi gli strumenti per l’aggiornamento alla versione 17.04, che non aiutano in quanto ora 17.10 è già stato rilasciato. Loro – ovviamente – consigliano esattamente entrambi i modi descritti sopra, ma seguirli risulta nella strana situazione che ho appena descritto.

Quindi le domande sono:

  • Come posso passare da 16.10 a 17.10?
  • O almeno: Come posso aggiornare 16.10 a 17.04 (in modo che io di conseguenza potrebbe essere in grado di aggiornare a 17.10)?

Ecco un esempio:

 [email protected]:~# apt update && apt dist-upgrade Hit:1 http://de.archive.ubuntu.com/ubuntu yakkety InRelease Hit:2 http://security.ubuntu.com/ubuntu yakkety-security InRelease Hit:3 http://de.archive.ubuntu.com/ubuntu yakkety-updates InRelease Hit:4 http://de.archive.ubuntu.com/ubuntu yakkety-backports InRelease Reading package lists... Done Building dependency tree Reading state information... Done All packages are up to date. Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. [email protected]:~# apt-get install update-manager-core Reading package lists... Done Building dependency tree Reading state information... Done update-manager-core is already the newest version (1:16.10.10). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. [email protected]:~# nano /etc/update-manager/release-upgrades [email protected]:~# do-release-upgrade -d Checking for a new Ubuntu release No new release found [email protected]:~# lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 16.10 Release: 16.10 Codename: yakkety [email protected]:~# 

Ovviamente il Prompt chiave in / etc / update-manager / release-upgrade è impostato su normal .

E do-release-upgrade -d porta a:

 [email protected]:~# do-release-upgrade -d Checking for a new Ubuntu release No new release found [email protected]:~# 

Nota: la domanda è: perché non esiste alcun percorso di aggiornamento? Anche se 16.10 e 17.04 non vengono più mantenuti, dovrebbe esserci un percorso di aggiornamento.


Poiché i moderatori non sembrano comprendere né le domande né le risposte e associano questa domanda a una domanda completamente non correlata e impediscono di fornire una risposta reale, non vedo un altro modo per fornire la risposta qui all’interno della domanda.

Risposta: non esiste un percorso di aggiornamento. Questo è il problema. Sì, è il modo in Ubuntu di non fornire un percorso di aggiornamento per le versioni non LTS non appena c’è anche una singola versione non LTS tra la versione corrente e quella più recente. Ciò rende completamente inutili le versioni non LTS dopo che sono state pubblicate due versioni non LTS. Non esiste un modo ufficiale di aggiornamento.

Quindi hai due opzioni:

a) Effettuare una reinstallazione con una versione più recente (LTS). Questa è la soluzione più pulita che puoi ottenere.

b) O fare del lavoro manuale con i rischi coinvolti seguendo le raccomandazioni fornite in questa risposta qui: Aggiornamento da Yakkety Yak (Ubuntu 16.10) quando la sua fine della vita

Questa domanda è – se non del tutto – un duplicato di QUELLA domanda appena menzionata.

Innanzitutto vorrei aggiungere che si tratta di un trucco e che i problemi potrebbero essere determinati o meno dal farlo. Ho provato solo questo con Ubuntu Server 16.10.

Sono riuscito ad aggiornare dalla versione server 16.10 alla 17.10 effettuando le seguenti operazioni:

Apri /etc/apt/sources.list:

 vim /etc/apt/sources.list 

Cambia tutti i riferimenti da yakkety a artful:

 :%s/yakkety/artful/g 

Fai un aggiornamento e aggiorna:

 apt update && apt upgrade 

Riavvia il sistema.

Dubito fortemente che sia davvero l’EOL il problema qui. Ho aggiornato MOLTO vecchie versioni senza problemi MOLTO. Di solito (dalla mia esperienza), viene semplicemente proposta la versione successiva. Quindi Yakkety dovrebbe essere aggiornato a Zesty da quello strumento – non immediatamente ad Artful come indicato nel messaggio di errore.

Forse è un difetto tecnico temporaneo dovuto al fatto che il 17.10 è stato sospeso per un po ‘a causa del fatto che i computer portatili sono in muratura. AFAIK questo problema è risolto ora, ma forse questo è ancora un po ‘fallout di questo incidente. Almeno questo spiegherà perché lo strumento vuole saltare il 17.10 del tutto.