Qualcomm Atheros Device (rev 30) Con Ubuntu 14.04 non funziona

Ho comprato un laptop Lenovo ideapad 300 e installato Ubuntu 14.04 su di esso. La scheda wifi del portatile è Qualcomm Atheros Device [168c: 0042] (rev 30).

Non voglio eseguire l’aggiornamento a 15.04 o 15.10 poiché eseguo software che in seguito verrà eseguito su server 14.04, quindi voglio mantenere il mio ambiente di sviluppo il più vicino ansible all’ambiente di esecuzione.

Ho letto che Ndiswrapper non funzionerà qui – Ndiswrapper non funzionerà

Ho quindi trovato Jeremy31 risposta qui – installa i backport

Ho eseguito i comandi nella risposta di Jeremy31 e riavviato, ma non ho visto alcun cambiamento. Dopo che ho eseguito i comandi, ho dmesg | grep ath10k dmesg | grep ath10k non mi ha dato niente. sudo modprobe ath10k_pci && dmesg | grep ath sudo modprobe ath10k_pci && dmesg | grep ath risultati di sudo modprobe ath10k_pci && dmesg | grep ath non sono rilevanti:

 [ 0.643855] Loaded X.509 cert 'Magrathea: Glacier signing key: e09b1e7e9841e9cfef256b70ab210562dab1ef68' [ 4855.547585] [] warn_slowpath_common+0x8a/0xc0 [ 4855.547587] [] warn_slowpath_fmt+0x46/0x50 

Apprezzerò un po ‘di aiuto per risolvere questo problema. Grazie in anticipo

Ecco il risultato dello script di informazioni wireless:

 ########## wireless info START ########## Report from: 14 Jan 2016 13:45 IST +0200 Booted last: 14 Jan 2016 08:29 IST +0200 Script from: 27 Sep 2015 00:34 UTC +0000 ##### release ########################### Distributor ID: Ubuntu Description: Ubuntu 14.04.3 LTS Release: 14.04 Codename: trusty ##### kernel ############################ Linux 3.19.0-43-generic #49~14.04.1-Ubuntu SMP Thu Dec 31 15:44:49 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux Parameters: ro, quiet, splash, vt.handoff=7 ##### desktop ########################### Ubuntu ##### lspci ############################# 01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15) Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:0123] Kernel driver in use: r8169 02:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 30) Subsystem: Lenovo Device [17aa:4035] ##### lsusb ############################# Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 004: ID 0cf3:e360 Atheros Communications, Inc. Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller Bus 001 Device 002: ID 04f2:b50e Chicony Electronics Co., Ltd Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub ##### PCMCIA card info ################## ##### rfkill ############################ 0: ideapad_wlan: Wireless LAN Soft blocked: no Hard blocked: no 1: ideapad_bluetooth: Bluetooth Soft blocked: yes Hard blocked: no 5: hci0: Bluetooth Soft blocked: yes Hard blocked: no ##### lsmod ############################# ideapad_laptop 24576 0 sparse_keymap 16384 1 ideapad_laptop wmi 20480 0 ##### interfaces ######################## auto lo iface lo inet loopback ##### ifconfig ########################## eth0 Link encap:Ethernet HWaddr  inet addr:192.168.1.30 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:522852 errors:0 dropped:0 overruns:0 frame:0 TX packets:321922 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:613510252 (613.5 MB) TX bytes:32176525 (32.1 MB) ##### iwconfig ########################## eth0 no wireless extensions. lo no wireless extensions. ##### route ############################# Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0 192.168.1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0 ##### resolv.conf ####################### nameserver 127.0.1.1 search Home ##### network managers ################## Installed: NetworkManager Running: root 770 1 0 08:28 ? 00:00:00 NetworkManager ##### NetworkManager info ############### NetworkManager Tool State: connected (global) - Device: eth0 [Wired connection 1] ------------------------------------------- Type: Wired Driver: r8169 State: connected Default: yes HW Address:  Capabilities: Carrier Detect: yes Speed: 100 Mb/s Wired Properties Carrier: on IPv4 Settings: Address: 192.168.1.30 Prefix: 24 (255.255.255.0) Gateway: 192.168.1.1 DNS: 192.168.1.1 ##### NetworkManager.state ############## [main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true WimaxEnabled=true ##### NetworkManager.conf ############### [main] plugins=ifupdown,keyfile,ofono dns=dnsmasq [ifupdown] managed=false ##### NetworkManager profiles ########### ##### iw reg get ######################## Region: Asia/Jerusalem (based on set time zone) country 00: (2402 - 2472 @ 40), (6, 20) (2457 - 2482 @ 40), (6, 20), PASSIVE-SCAN (2474 - 2494 @ 20), (6, 20), NO-OFDM, PASSIVE-SCAN (5170 - 5250 @ 160), (6, 20), PASSIVE-SCAN (5250 - 5330 @ 160), (6, 20), DFS, PASSIVE-SCAN (5490 - 5730 @ 160), (6, 20), DFS, PASSIVE-SCAN ##### iwlist channels ################### eth0 no frequency information. lo no frequency information. ##### iwlist scan ####################### eth0 Interface doesn't support scanning. lo Interface doesn't support scanning. ##### module infos ###################### ##### module parameters ################# ##### /etc/modules ###################### lp rtc ##### modprobe options ################## [/etc/modprobe.d/ath10k_core.conf] options ath10k_core skip_otp=y [/etc/modprobe.d/blacklist-ath_pci.conf] blacklist ath_pci [/etc/modprobe.d/blacklist.conf] blacklist evbug blacklist usbmouse blacklist usbkbd blacklist eepro100 blacklist de4x5 blacklist eth1394 blacklist snd_intel8x0m blacklist snd_aw2 blacklist i2c_i801 blacklist prism54 blacklist bcm43xx blacklist garmin_gps blacklist asus_acpi blacklist snd_pcsp blacklist pcspkr blacklist amd76x_edac [/etc/modprobe.d/blacklist-rare-network.conf] alias net-pf-3 off alias net-pf-6 off alias net-pf-9 off alias net-pf-11 off alias net-pf-12 off alias net-pf-19 off alias net-pf-21 off alias net-pf-36 off [/etc/modprobe.d/iwlwifi.conf] remove iwlwifi \ (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \ && /sbin/modprobe -r mac80211 [/etc/modprobe.d/mlx4.conf] softdep mlx4_core post: mlx4_en ##### rc.local ########################## exit 0 ##### pm-utils ########################## ##### udev rules ######################## [/etc/udev/rules.d/70-persistent-net.rules] # PCI device 0x10ec:0x8168 (r8169) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0" ##### dmesg ############################# [14691.294859] WARNING: CPU: 0 PID: 21023 at /build/linux-lts-vivid-xAeXSD/linux-lts-vivid-3.19.0/drivers/base/firmware_class.c:1126 _request_firmware+0xb47/0xb90() [14691.295253] [] ? _request_firmware+0x5a/0xb90 [14691.295281] [] _request_firmware+0xb47/0xb90 [14691.295303] [] request_firmware+0x35/0x50 [14691.295619] bluetooth hci0: firmware: qca/rampatch_usb_00000300.bin will not be loaded [14692.745370] r8169 0000:01:00.0 eth0: link down (repeated 2 times) [14692.745658] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [14696.283402] r8169 0000:01:00.0 eth0: link up [14696.283420] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready ########## wireless info END ############ 

Aggiungere le informazioni per modinfo ath10k_pci; dkms status modinfo ath10k_pci; dkms status :

 filename: /lib/modules/3.19.0-43-generic/kernel/drivers /net/wireless /ath/ath10k/ath10k_pci.ko firmware: ath10k/QCA988X/hw2.0/board.bin firmware: ath10k/QCA988X/hw2.0/firmware-3.bin firmware: ath10k/QCA988X/hw2.0/firmware-2.bin firmware: ath10k/QCA988X/hw2.0/firmware.bin license: Dual BSD/GPL description: Driver support for Atheros QCA988X PCIe devices author: Qualcomm Atheros srcversion: 06FDAE7EFB4CDD527508269 alias: pci:v0000168Cd0000003Csv*sd*bc*sc*i* depends: ath10k_core intree: Y vermagic: 3.19.0-43-generic SMP mod_unload modversions signer: Magrathea: Glacier signing key sig_key: E0:9B:1E:7E:98:41:E9:CF:EF:25:6B:70:AB:21:05:62:DA:B1:EF:68 sig_hashalgo: sha512 parm: irq_mode:0: auto, 1: legacy, 2: msi (default: 0) (uint) parm: reset_mode:0: auto, 1: warm only (default: 0) (uint) 

Reinstallare i backport usando

 cd backports-20151120 make clean make make defconfig-ath10k sudo make install 

Riavvia e verifica se il nome del file in modinfo ath10k_pci mostra una posizione di /lib/modules/3.19.0-43-generic/kernel/updates/ath10k_pci.ko