Aggiornato alla 18.04 e ora ha molti pacchetti rotti e dipendenze non soddisfatte

Ho fatto un terribile errore e aggiornato alla 18.04 senza fare un backup in una partizione diversa facendo:

sudo apt update sudo apt upgrade sudo apt dist-upgrade sudo apt-get autoremove sudo apt install update-manager-core sudo do-release-upgrade -d 

Quindi ho aggiornato e aggiornato i comandi dopo un riavvio. Ora ci sono molti problemi con dipendenze non soddisfatte e pacchetti danneggiati che i comandi sudo apt-get -f install non possono correggere. AGGIORNAMENTO La prima parte dell’output del log degli errori di sudo apt install -f è:

  Reading package lists... Building dependency tree... Reading state information... Correcting dependencies... failed. The following packages have unmet dependencies: gnome-calendar : Depends: gsettings-desktop-schemas (>= 3.21.2) but 3.18.1-1ubuntu1 is installed gnome-session : Depends: gnome-shell (>= 3.25.91-0ubuntu4~) but it is not installed Depends: gnome-session-bin (>= 3.28.1-0ubuntu2) but 3.18.1.2-1ubuntu1.16.04.2 is installed Depends: gnome-session-common (= 3.28.1-0ubuntu2) but 3.18.1.2-1ubuntu1.16.04.2 is installed Depends: xwayland but it is not installed Recommends: fonts-cantarell but it is not installed Recommends: adwaita-icon-theme-full Recommends: gnome-themes-extra but it is not installed gnome-settings-daemon : Depends: libgnome-desktop-3-17 (>= 3.17.92) but it is not installed Depends: gsettings-desktop-schemas (>= 3.20) but 3.18.1-1ubuntu1 is installed hplip : Depends: python3 (< 3.6) but 3.6.5-3 is installed libc-dev-bin : Depends: libc6 (= 1.7.0) but 1.6.0-1 is installed libreoffice-avmedia-backend-gstreamer : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial3) but 1:6.0.3-0ubuntu1 is installed libreoffice-base-core : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial3) but 1:6.0.3-0ubuntu1 is installed libreoffice-calc : Depends: libreoffice-base-core (= 1:6.0.3-0ubuntu1) but 1:5.1.6~rc2-0ubuntu1~xenial3 is installed Depends: liborcus-0.13-0 (>= 0.13.3) but it is not installed libreoffice-core : Depends: libgpgmepp6 (>= 1.10.0) but it is not installed Depends: liborcus-0.13-0 (>= 0.13.3) but it is not installed Depends: libpoppler73 (>= 0.62.0) but it is not installed Depends: libxmlsec1 (>= 1.2.25) but it is not installed Depends: libxmlsec1-nss (>= 1.2.25) but it is not installed libreoffice-gnome : Depends: libreoffice-gtk3 but it is not installed libreoffice-gtk : Depends: libreoffice-gtk2 but it is not installed libreoffice-math : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial3) but 1:6.0.3-0ubuntu1 is installed libreoffice-writer : Depends: libreoffice-base-core (= 1:6.0.3-0ubuntu1) but 1:5.1.6~rc2-0ubuntu1~xenial3 is installed Depends: libabw-0.1-1 but it is not installed Depends: libepubgen-0.1-1 (>= 0.1.0) but it is not installed libtotem0 : Depends: libgnome-desktop-3-17 (>= 3.17.92) but it is not installed libwayland-egl1-mesa : Depends: libegl1 but it is not installed libwebkitgtk-1.0-0 : Depends: libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1) but 2.4.11-3ubuntu3 is installed Depends: libwebkitgtk-1.0-common (>= 2.4.11) but it is not installable nautilus : Depends: libgnome-desktop-3-17 (>= 3.18.1) but it is not installed python3-brlapi : Depends: python3 (< 3.6) but 3.6.5-3 is installed python3-cffi-backend : Depends: python3 (< 3.6) but 3.6.5-3 is installed python3-crypto : Depends: python3 (< 3.6) but 3.6.5-3 is installed 

e

 E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

Cercando di correggere i pacchetti danneggiati in Synaptic viene visualizzato questo messaggio di errore:

 E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

Non sembra che ci sia qualcosa di sbagliato nel file sources.list e sembra che sia stato aggiornato quando ho provato l’installazione. So a malapena cosa sto facendo e sono lieto di fornire maggiori dettagli sui messaggi di errore. Se c’è un modo per abilitare lo scorrimento su in xterm, che è quello che sto usando dal momento che il terminale Gnome non può essere aperto.

Mi piacerebbe rimuovere tutti i 47 pacchetti danneggiati e contenere i pacchetti, reinstallarli correttamente o non installarli per ora se questa è un’opzione (ad esempio, per cose come LibreOffice, che non è una necessità attuale), ed essere in grado di usare il Terminale Gnome.

Sto cercando passaggi per principianti su come risolvere tutti questi problemi. C’è una guida su come iniziare? Un post ovvio che ho perso nelle mie ricerche di risposte? Penso che questo post stia andando nella giusta direzione, ma è un po ‘sopra la mia testa. Ogni aiuto è molto apprezzato. Mi chiedo se sarebbe davvero più facile iniziare da una nuova installazione 16.04.

Ho avuto lo stesso identico problema. Dovevo andare a modificare /var/lib/dpkg/status e cancellare l’intera Depends: line dai pacchetti che si lamentavano.
Non sono sicuro di quali altri problemi possano causare, ma è stata l’unica cosa che ha reso apt-get install -f funzionante di nuovo.

Ecco un paio di cose da provare.

Metodo uno:

Questo è il più facile da provare. Invece di usare sudo apt-get install PACKAGENAME, dove PACKAGENAME è il pacchetto che stai cercando di installare con il sistema apt, usa sudo apt-get install -f. Il parametro -f tenterà di correggere un sistema che ha delle dipendenze non funzionanti, dopo di che sarete in grado di installare il pacchetto in questione.

Apri un terminale e digita:

 sudo apt-get install -f 

e premere INVIO.

Ora digita:

 sudo dpkg --configure -a 

e premere INVIO.

Ora un’altra volta:

 sudo apt-get install -f 

Metodo due:

Aptitude è un’alternativa di apt-get che puoi utilizzare come gestore di pacchetti di livello superiore. Puoi usarlo per provare e installare il tuo pacchetto con esso, invece di apt-get, ma prima devi installare aptitude.

Apri un terminale e digita:

 sudo apt-get install aptitude 

e premere INVIO.

Ora digita:

 sudo aptitude install PACKAGENAME 

e premere INVIO.

PACKAGENAME è il pacchetto che stai installando. Questo tenterà di installare il pacchetto tramite aptitude anziché apt-get, che dovrebbe potenzialmente risolvere il problema delle dipendenze non soddisfatte.

SE NON FUNZIONANO

Il pacchetto rotto è probabilmente chiuso a chiave e deve essere eliminato. Per eliminare il file bloccato, apri un Terminale e digita:

 sudo rm /var/lib/apt/lists/lock 

e premere INVIO.

Potrebbe inoltre essere necessario eliminare il file bloccato nella directory della cache. Per farlo, apri un Terminale e digita:

 sudo rm /var/cache/apt/archives/lock 

Ho aggiornato dal 16.04 e ho riscontrato molti problemi diversi. Ho trovato molto più facile fare una nuova installazione. Un’installazione fresca o pulita è sempre la strada da percorrere secondo me.

Spero che questo ti aiuti,

Voglio aggiungere a questa discussione dicendo che quando si usa il software di aggiornamento per eseguire l’aggiornamento alla 18.04 e in esecuzione in un problema la soluzione è quella di aprire il terminale e digitare:

 sudo apt-get autoremove 

seguito da ciò che inizialmente ha causato delle cose sbagliate qui che hanno portato a questa discussione che come segue:

 sudo apt update sudo apt upgrade sudo apt dist-upgrade sudo apt-get autoremove sudo apt install update-manager-core sudo do-release-upgrade -d 

“Se c’è un modo per abilitare lo scorrimento su in xterm” poiché non è ansible scorrere verso l’alto è ansible inviare tutti gli output a un file usando:

 sudo apt install -f > output.log 

Quindi modifica output.log e copia i messaggi nella tua domanda. Le tue possibilità di ottenere una buona risposta migliorano con ulteriori informazioni.


Per quanto riguarda chiunque voglia copiare i propri dati su una partizione di backup prima di passare alla versione 18.04, ecco il comando preso in prestito da questa risposta: script Bash per clonare Ubuntu sulla nuova partizione per il test dell’aggiornamento LTS 18.04

 rsync -haxAX --stats --delete --info=progress2 --info=name0 /* "$TargetMnt" \ --exclude={/dev/*,/proc/*,/sys/*,/tmp/*,/run/*,/mnt/*,/media/*,/lost+found} 

Prima di eseguire il comando è necessario creare una partizione di backup e montarla. Dopo averlo montato, impostare:

 TargetMnt=/mnt/my_backup_partition_name 

Ovviamente un metodo più semplice è semplicemente eseguire lo script collegato sopra. Non solo fornisce la selezione intertriggers della partizione di backup ma fornisce la convalida e modifica grub modo da poter eseguire l’avvio nella partizione di backup, se necessario.

PS Sono triste sentire i tuoi problemi e molti altri problemi che ho letto qui su Ask Ubuntu dall’uscita del 18.04. Sfortunatamente vedi problemi simili con ogni nuova versione. Speriamo che un giorno Conical sottolinei l’importanza del backup e / o del test su una partizione clone prima di eseguire l’aggiornamento. Soprattutto prima del rilascio del primo punto del 18.04.1 che arriverà il 26 luglio 2018.

In effetti ho avuto troppi problemi nell’aggiornamento da Xubuntu dal 16.04 al 18.04. Ho dovuto rimuovere completamente gstreamer dal sistema (non funziona con pulseaudio, che si comporta in modo strano), a parte molti altri problemi non correlati a questo post (nvidia, netplan, baloo). In molti anni di gestione di desktop e server è stata la mia migrazione più difficile. Quindi non consiglio l’ugrading alla 18.04 prima che sia una distribuzione stabile.

se hai un sistema che non riesci ad accedere poi vai al login tty1 da cltr + alt + F1 accedi al tuo account e prova questo sudo apt-get install -f dist-upgrade se ti chiede una soluzione particolare per applicare Y / n usa l’altra opzione digitando “.” per l’altra soluzione, allora sei elencato con un’altra soluzione per aggiornare completamente il tuo sistema. se si verifica qualche problema fammelo sapere